Hi Ian. I just checked out FormEncode. The API looks really nice! Great work. I'll keep it in mind the next time i'm doing a web programming project.
Would you consider renaming ForEach, though? It doesn't make sense to me -- i think List or ListOf would be a much clearer name.